Answered By: Anna Burke
Last Updated: Aug 24, 2017     Views: 251

Want to go all https with your Springshare product? You totally can! With browsers' increased alerts about non-https sites, we've been busy behind-the-scenes here at Springy HQ to ensure your https experience is as easy as possible.

LibGuides

Domains

If your LibGuides site is using a libguides.com domain (e.g., springylib.libguides.com), you're all set! You can update all links to your site to include https right now (e.g., https://springylib.libguides.com).

If your LibGuides site is using a custom domain (anything not on libguides.com, e.g., support.springshare.com), you'll need to work with your IT department to purchase a security certificate for your domain, then a LibApps Admin for your site can go to LibApps > Admin > Manage Domains to upload & install it. Read through our guide for exact steps!

Widgets / APIs

LibGuides widgets are protocol-less, so they'll just work without having to do any specific updates...though if you want them on https specifically, just add that to the widget's src URL.

LibGuides APIs can also be used either over http or https, so just make sure your API calls are using https!


LibAnswers

Domains

If your LibAnswers site is using a libanswers.com domain (e.g., springylib.libanswers.com), you're all set! You can update all links to your site to include https right now (e.g., https://springylib.libanswers.com).

If your LibAnswers site is using a custom domain (anything not on libanswers.com, e.g., ask.springshare.com), you'll need to work with your IT department to purchase a security certificate for your domain, then work with us to install it for your site. Shortly you'll be able to manage the installation process yourselves in LibApps, just like you can for LibGuides, but for now you'll need to contact our support team.

Widgets / APIs

LibAnswers widgets (except LibChat) are protocol-less, which means they'll just work over http or https without having to do any specific updates to the widgets. All LibChat widgets and all API calls are https by default, so you do not need to update them.

LibAnswers has a setting to force all widget / API traffic through https. Admins can enable this at: Admin > System Settings > Access Rules & Privacy > API/Widgets > Require API/Widget access via https. Once enabled, you'll need to ensure that https: is added to the beginning of every widget/API src URL. See an example in our documentation.


LibCal

Domains

If your LibCal site is using a libcal.com domain (e.g., springylib.libcal.com), you're all set! You can update all links to your site to include https right now (e.g., https://springylib.libcal.com).

If your LibCal site is using a custom domain (anything not on libcal.com, e.g., calendar.springshare.com), you'll need to work with your IT department to purchase a security certificate for your domain, then work with us to install it for your site. Shortly you'll be able to manage the installation process yourselves in LibApps, just like you can for LibGuides, but for now you'll need to contact our support team.

Widgets / APIs

LibCal widgets are either https by default or protocol-less (can be loaded via http or https), which means no updates should be required. If you want to ensure everything loads over https, though, check your widgets and add https: to the beginning of the src URL, if it's not already there.

LibCal APIs are https by deafult, so no updates should be required.


LibWizard

Domains

Since all LibWizard sites are on the libwizard.com or libsurveys.com domains, you can use https at any time. We have wildcard security certificates for both libwizard.com and libsurveys.com, which cover your site.

Widgets / APIs

LibWizard widgets are protocol-less, so they'll just work without having to do any specific updates...though if you want them on https specifically, just add that to the widget's src URL.


LibInsight

Domains

Since all LibInsight sites are on the libinsight.com domain, you can use https at any time. We have a wildcard security certificate for libinsight.com, which covers your site.

Widgets / APIs

LibInsight widgets and APIs are https by default, so no updates should be necessary.


LibStaffer

Domains

Since all LibStaffer sites are on the libstaffer.com domain, you can use https at any time. We have a wildcard security certificate for libstaffer.com, which covers your site.


LibCRM

Domains

Since all LibCRM sites are on the libcrm.com domain, you can use https at any time. We have a wildcard security certificate for libcrm.com, which covers your site.

Comments (0)

Related Topics

    Contact Us